La función SUMAR.SI de Excel

Otra función útil de Excel es SUMAR.SI. Esta función es como CONTAR.SI, excepto que agrega un argumento más:
 
SUMAR.SI(rango, "criterio", rango suma)

 
El rango y los criterios son los mismos que con CONTAR.SI: el rango de celdas para buscar y lo que desea que busque Excel. Rango suma es como el rango, pero busca un nuevo rango de celdas. Para aclarar todo eso, esto es para lo que usaremos SUMAR.SI. (Comience una nueva hoja de cálculo para esto).
 
Cinco personas nos han pedido productos. Algunos nos han pagado, pero otros no. Las cinco personas son Elisa, Kelly, Steven, Euan y Holly. Usaremos SUMAR.SI para calcular cuánto nos pagaron en total y cuánto se nos debe.

 
Entonces, en la columna A, ingrese los nombres:
 
Cree la siguiente hoja de cálculo de Excel 2007


En la columna B, ingrese cuánto debe cada persona:
 


En la columna C, ingrese los valores VERDADERO o FALSO. VERDADERO significa que han pagado, y FALSO significa que no:
 


Agregue dos etiquetas más: Total Pagado y Aún Debido. Su hoja de cálculo debería parecerse a esta:
 


En las celdas B10 y B11, usaremos una función SumIF para calcular cuánto se ha pagado y cuánto se debe. Aquí está la función SumIF nuevamente:
 
=SUMAR.SI(rango, "criterio", rango suma)
 
Entonces, el rango de celdas que queremos verificar son los valores Verdadero y Falso en la columna C; el criterio es si han pagado (Verdadero); y rango suma es lo que queremos sumar (en la columna B).
 
En la celda B10, ingrese la siguiente fórmula:
 
=SUMAR.SI(B2:B5, "Verdadero", C2:C5)


Cuando presiona la tecla Intro, Excel debería darle la respuesta:
 


Entonces se ha pagado 265. Pero le dijimos a SUMAR.SI que primero verificara los valores en las celdas C3 a C7 (rango). Luego dijimos buscar un valor de VERDADERO (criterio). Finalmente, queríamos que los valores en la columna B sumaran, si efectivamente se encontró un criterio de VERDADERO (rango_sum).
 
Ejercicio
 
Use SUMAR.SI para calcular cuánto se debe todavía. Escriba su respuesta en la celda B11.
 
Dejaremos el tema de la lógica condicional. En la siguiente sección, ¡más cosas que puede hacer con Excel!
 

Comentarios